1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Super Low FPS with Good Rig?

Discussion in 'Game/account support' started by GamingWithDon, Oct 16, 2016.

  1. GamingWithDon

    GamingWithDon New Member

    Joined:
    Oct 16, 2016
    Messages:
    4
    Likes Received:
    2
    [​IMG]
    Here are my specs. No matter if the game is all low/disabled or everything ultra/on I get around 35 fps.
    If I go on normal ISS or any other emulator I get 140 fps so It's not my pc.
    What is causing this, I'm trying to stream the game and its really unplayable for me because of the performance.
     
  2. GamingWithDon

    GamingWithDon New Member

    Joined:
    Oct 16, 2016
    Messages:
    4
    Likes Received:
    2
  3. Lars

    Lars Administrator
    Staff Member

    Joined:
    Sep 5, 2016
    Messages:
    383
    Likes Received:
    225
    Hi,

    This is a problem that I will investigate this week. Hopefully I can find a solution but it's just a very strange thing. There is a streamer with an i5 processor and also a GTX 970 and he gets a constant 70-80 FPS while streaming and playing on High/Ultra.
     
    GamingWithDon likes this.
  4. Nevakonaza

    Nevakonaza Member
    Legend

    Joined:
    Sep 5, 2016
    Messages:
    89
    Likes Received:
    24
    Not saying this will fix the issue for you,But its worth a try i guess as like mentioned above,I have an i7 with a GTX 970 and have no performance issues at all.

    Things to try to see if they improve anything.

    • Disable Core parking (google this)
    • Choose "High performance" power plan.
    • In "Nvidia control panel" under "Physx" you could try "CPU" setting,Or maybe "GTX 970"

    Like i said,may not help with anything,but no harm in trying.
     
    Lars likes this.
  5. GamingWithDon

    GamingWithDon New Member

    Joined:
    Oct 16, 2016
    Messages:
    4
    Likes Received:
    2
    I already have all of this, but thanks for the tips.
     
  6. GamingWithDon

    GamingWithDon New Member

    Joined:
    Oct 16, 2016
    Messages:
    4
    Likes Received:
    2
    So I found the cause for my low fps.
    I found out when I saw that a blank process in task manager was using 50% of my cpu usage.
    I right click it and "go to details" turns out its svchost, so I think nothing of it since its a windows process etc etc.
    I dig a little deeper and try to end the process tree, the virus tries to reinjects itself 5 more times and windows defender catches it,
    I then restart my pc and reboot. The miner tries to launch another 4 more times catching it again, I think its gone for good now.

    Now I get a stable 80 fps on low, which still isnt great for this game but atleast playable.

    So kids makes sure you check everything you download etcetc

    -Don
     
    Lars and DraefeN like this.
  7. Mumpyz

    Mumpyz New Member

    Joined:
    Oct 15, 2016
    Messages:
    28
    Likes Received:
    1
    I have the same problem here, extreme low fps
     
  8. Midnajt

    Midnajt New Member
    Legend

    Joined:
    Oct 16, 2016
    Messages:
    10
    Likes Received:
    6
    same here
     
  9. Kaydiddy

    Kaydiddy New Member

    Joined:
    Oct 16, 2016
    Messages:
    3
    Likes Received:
    1
    One problem i had earlier on other emulators aswell was the driver version i used. I have a gtx 970/oc and im using the newest driver version and i dont have the problem. Try a older driver version, i used to install older drivers earlier and it fixed my fps from 20-40fps to 120-200fps. - http://www.nvidia.co.uk/download/driverResults.aspx/102485/en-uk (Windows10 Version) one older version but u can search for your own in the beta and archieve section on nvidia drivers so u can test around, good luck.

    Greeting
    KayDiddy
     
    Lars likes this.